blob: d98fb4c7583166c3f3fc0185d5a07e9a90483d28 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001inherit python3-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -05002
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
4EXTRANATIVEPATH += "python3-native"
5DEPENDS_append = " python3-native "
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006
7# python-config and other scripts are using distutils modules
8# which we patch to access these variables
9export STAGING_INCDIR
10export STAGING_LIBDIR
11
Brad Bishop79641f22019-09-10 07:20:22 -040012# Packages can use
13# find_package(PythonInterp REQUIRED)
14# find_package(PythonLibs REQUIRED)
15# which ends up using libs/includes from build host
16# Therefore pre-empt that effort
17export PYTHON_LIBRARY="${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so"
18export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}"
19
Brad Bishop19323692019-04-05 15:28:33 -040020export _PYTHON_SYSCONFIGDATA_NAME="_sysconfigdata"
21
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022# suppress host user's site-packages dirs.
23export PYTHONNOUSERSITE = "1"
24
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025# autoconf macros will use their internal default preference otherwise
26export PYTHON