blob: a60e851897da5a7f6a85dcf6ef041dd0429e56ab [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Program for creating simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5DEPENDS = "autoconf-native automake-native"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
Brad Bishop79641f22019-09-10 07:20:22 -04008SRC_URI[md5sum] = "dd322adcaede5bd5eaed075ff8971bc1"
9SRC_URI[sha256sum] = "5985b257f86304c8791842c0c807a37541d0d6807ee973000cf8a3fe6ad47b88"
Brad Bishopc342db32019-05-15 21:57:59 -040010
11inherit autotools native
12
13EXTRA_OECONF = "--disable-nls"
14
15# We don't want to reconfigure things as it would require 'perlnative' to be
16# used.
17do_configure() {
18 oe_runconf
19}
20
21do_install_append () {
22 # Make sure we use /usr/bin/env perl
23 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
24}