blob: b0f565b9b077e6724aa74c8ce7a54354fad273fe [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
Brad Bishop08902b02019-08-20 09:16:51 -04007LIC_FILES_CHKSUM = "file://COPYING;md5=e11f5c3149cdec4bb309babb020b32b9 \
Brad Bishop79641f22019-09-10 07:20:22 -04008 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
Brad Bishopc342db32019-05-15 21:57:59 -04009
10DEPENDS = "glib-2.0 cairo fontconfig freetype"
11
Brad Bishop08902b02019-08-20 09:16:51 -040012SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.xz"
Brad Bishop79641f22019-09-10 07:20:22 -040013SRC_URI[md5sum] = "89b758a2eb14d56a94406cf914b62388"
14SRC_URI[sha256sum] = "c651fb3faaa338aeb280726837c2384064cdc17ef40539228d88a1260960844f"
Brad Bishopc342db32019-05-15 21:57:59 -040015
16inherit autotools pkgconfig lib_package gtk-doc
17
18PACKAGECONFIG ??= "icu"
19PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
Brad Bishop79641f22019-09-10 07:20:22 -040020PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
Brad Bishopc342db32019-05-15 21:57:59 -040021
22EXTRA_OECONF = " \
23 --with-cairo \
24 --with-fontconfig \
25 --with-freetype \
26 --with-glib \
Brad Bishopc342db32019-05-15 21:57:59 -040027"
28
29PACKAGES =+ "${PN}-icu ${PN}-icu-dev"
30
31LEAD_SONAME = "libharfbuzz.so"
32
33FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
34FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
35 ${libdir}/libharfbuzz-icu.so \
36 ${libdir}/pkgconfig/harfbuzz-icu.pc \
37"
38
39BBCLASSEXTEND = "native nativesdk"