blob: db9ce5d5e6e997e89c1bfb56da39181cbcc56cbd [file] [log] [blame]
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05301SUMMARY = "OpenPower OCC Control with MRW generated sensor IDs"
2PR = "r1"
Brad Bishop2879d322018-11-07 14:45:23 -05003LICENSE = "Apache-2.0"
Brad Bishop1ebdb612019-09-13 12:18:25 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05305
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05306inherit openpower-occ-control
Matt Spinler0a8ea632017-12-14 13:31:55 -06007inherit mrw-xml
Joseph Reynolds79809ea2021-02-26 15:37:31 -06008inherit native
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05309
10PROVIDES += "virtual/openpower-occ-control-config-native"
11DEPENDS += "mrw-native mrw-perl-tools-native"
12
13# Generate a YAML files based on MRW input
14do_install_append() {
15 install -d ${YAML_DEST}/
16 ${STAGING_BINDIR_NATIVE}/perl-native/perl \
17 ${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060018 -i ${mrw_datadir}/${MRW_XML} \
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +053019 -o ${YAML_DEST}/occ_sensor.yaml
20}