Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | SUMMARY = "Management suite for extremely large and complex data collections" |
| 2 | DESCRIPTION = "Unique technology suite that makes possible the management of \ |
| 3 | extremely large and complex data collections" |
| 4 | HOMEPAGE = "https://www.hdfgroup.org/" |
| 5 | SECTION = "libs" |
| 6 | |
| 7 | LICENSE = "HDF5" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=ac1039f6bf7c9ab2b3693836f46d0735" |
| 9 | |
| 10 | inherit cmake siteinfo qemu |
| 11 | |
| 12 | DEPENDS += "qemu-native" |
| 13 | |
| 14 | SRC_URI = " \ |
| 15 | https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.13/hdf5-${PV}/src/${BPN}-${PV}.tar.bz2 \ |
| 16 | file://0002-Remove-suffix-shared-from-shared-library-name.patch \ |
| 17 | file://0001-cmake-remove-build-flags.patch \ |
| 18 | " |
| 19 | SRC_URI[sha256sum] = "9c51b3da426977ec622a43dca8adaf4e81eabf838c1ff80c6225ad1d3ed54b5c" |
| 20 | |
| 21 | FILES:${PN} += "${libdir}/libhdf5.settings ${datadir}/*" |
| 22 | |
| 23 | EXTRA_OECMAKE = " \ |
| 24 | -DHDF5_INSTALL_CMAKE_DIR=${libdir}/cmake \ |
| 25 | -DCMAKE_INSTALL_PREFIX='${prefix}' \ |
| 26 | -DHDF5_INSTALL_LIB_DIR='${baselib}' \ |
| 27 | " |
| 28 | EXTRA_OECMAKE:prepend:class-target = "-DCMAKE_CROSSCOMPILING_EMULATOR=${WORKDIR}/qemuwrapper " |
| 29 | |
| 30 | gen_emu() { |
| 31 | # Write out a qemu wrapper that will be used by cmake |
| 32 | # so that it can run target helper binaries through that. |
| 33 | qemu_binary="${@qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST'), [d.expand('${STAGING_DIR_HOST}${libdir}'),d.expand('${STAGING_DIR_HOST}${base_libdir}')])}" |
| 34 | cat > ${WORKDIR}/qemuwrapper << EOF |
| 35 | #!/bin/sh |
| 36 | $qemu_binary "\$@" |
| 37 | EOF |
| 38 | chmod +x ${WORKDIR}/qemuwrapper |
| 39 | } |
| 40 | |
| 41 | do_unpack[postfuncs] += "gen_emu" |
| 42 | |
| 43 | do_install:append() { |
| 44 | # Used for generating config files on target |
| 45 | install -m 755 ${B}/bin/H5detect ${D}${bindir} |
| 46 | install -m 755 ${B}/bin/H5make_libsettings ${D}${bindir} |
| 47 | } |
| 48 | |
| 49 | BBCLASSEXTEND = "native" |
| 50 | |
| 51 | SRC_DISTRIBUTE_LICENSES += "HDF5" |
| 52 | |
| 53 | # h5fuse.sh script needs bash |
| 54 | RDEPENDS:${PN} += "bash" |