blob: c09e5dd02bcfe5be65a4eb3907d9b2e37911a84e [file] [log] [blame]
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05001SUMMARY = "PLDM Stack"
2DESCRIPTION = "Implementation of the PLDM specifications"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit meson pkgconfig
7
8require pldm.inc
9
10DEPENDS += "systemd"
11DEPENDS += "phosphor-logging"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "nlohmann-json"
14DEPENDS += "boost"
15DEPENDS += "cli11"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMESON = " \
20 -Dtests=disabled \
21 -Doem-ibm=disabled \
22 "