blob: 6381917bb7332732f42834448bb66a10e344cc5d [file] [log] [blame]
Thang Q. Nguyen7b3a9f52023-10-19 10:19:11 +07001FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2
3SRC_URI:append = " file://host_eid"
4
5SYSTEMD_SERVICE:${PN}:remove = " \
6 pldmSoftPowerOff.service \
7 "
8SRC_URI:remove = "file://pldm-softpoweroff"
9
10EXTRA_OEMESON:append = " \
11 -Dtransport-implementation=af-mctp \
12 "
13
14do_install:append() {
15 install -d ${D}/${datadir}/pldm
16 install ${WORKDIR}/host_eid ${D}/${datadir}/pldm/
17 LINK="${D}${systemd_unitdir}/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
18 rm -f $LINK
19 LINK="${D}${systemd_unitdir}/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
20 rm -f $LINK
21 rm -f ${D}${systemd_unitdir}/system/pldmSoftPowerOff.service
22 rm -rf ${D}/${bindir}/pldm-softpoweroff
23}