blob: cd346b1232caf28eacdb174f4370af180e93e167 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001inherit deploy
2
3LICENSE = "Proprietary"
Andrew Geissler84ad7c52020-06-27 00:00:16 -05004LIC_FILES_CHKSUM = "file://../../../../license.txt;md5=39ab6ab638f4d1836ba994ec6852de94"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
Andrew Geissler84ad7c52020-06-27 00:00:16 -05006SRCREV = "e8db5fb118229fdc621e0ec7848641a23bf60998"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007PV = "${XILINX_RELEASE_VERSION}+git${SRCPV}"
8
9SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1"
10
11COMPATIBLE_HOST = "microblaze.*-elf"
Andrew Geissler84ad7c52020-06-27 00:00:16 -050012COMPATIBLE_MACHINE = "versal-mb"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14
Andrew Geissler84ad7c52020-06-27 00:00:16 -050015S = "${WORKDIR}/git/lib/sw_apps/versal_psmfw/src"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
17# The makefile does not handle parallelization
18PARALLEL_MAKE = ""
19
20do_configure() {
21 # manually do the copy_bsp step first, so as to be able to fix up use of
22 # mb-* commands
23 ${S}/../misc/copy_bsp.sh
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024}
25
26COMPILER = "${CC}"
27COMPILER_FLAGS = "-O2 -c"
28EXTRA_COMPILER_FLAGS = "-g -Wall -Wextra -Os -flto -ffat-lto-objects"
29ARCHIVER = "${AR}"
30
Andrew Geissler84ad7c52020-06-27 00:00:16 -050031BSP_DIR ?= "${S}/../misc/versal_psmfw_bsp"
32BSP_TARGETS_DIR ?= "${BSP_DIR}/psv_psm_0/libsrc"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34def bsp_make_vars(d):
35 s = ["COMPILER", "CC", "COMPILER_FLAGS", "EXTRA_COMPILER_FLAGS", "ARCHIVER", "AR", "AS"]
36 return " ".join(["\"%s=%s\"" % (v, d.getVar(v)) for v in s])
37
38do_compile() {
39 # the Makefile in ${S}/../misc/Makefile, does not handle CC, AR, AS, etc
40 # properly. So do its job manually. Preparing the includes first, then libs.
41 for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
42 oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)}
43 done
44 for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
45 oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)}
46 done
47
48 # --build-id=none is required due to linker script not defining a location for it.
49 # Again, recipe-systoot include is necessary
50 oe_runmake CC="${CC}" CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
51}
52
53do_install() {
54 :
55}
56
Andrew Geissler84ad7c52020-06-27 00:00:16 -050057PSM_FIRMWARE_BASE_NAME ?= "${BPN}-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
58PSM_FIRMWARE_BASE_NAME[vardepsexclude] = "DATETIME"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080059
60do_deploy() {
Andrew Geissler84ad7c52020-06-27 00:00:16 -050061 install -Dm 0644 ${B}/psmfw.elf ${DEPLOYDIR}/${PSM_FIRMWARE_BASE_NAME}.elf
62 ln -sf ${PSM_FIRMWARE_BASE_NAME}.elf ${DEPLOYDIR}/${BPN}-${MACHINE}.elf
63 ${OBJCOPY} -O binary ${B}/psmfw.elf ${B}/psmfw.bin
64 install -m 0644 ${B}/psmfw.bin ${DEPLOYDIR}/${PSM_FIRMWARE_BASE_NAME}.bin
65 ln -sf ${PSM_FIRMWARE_BASE_NAME}.bin ${DEPLOYDIR}/${BPN}-${MACHINE}.bin
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080066}
67
68addtask deploy before do_build after do_install
69