Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "GNU file archiving program" |
| 2 | DESCRIPTION = "GNU tar saves many files together into a single tape \ |
| 3 | or disk archive, and can restore individual files from the archive." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/tar/" |
| 5 | SECTION = "base" |
| 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2 \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 10 | file://musl_dirent.patch \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "17917356fff5cb4bd3cd5a6c3e727b05" |
| 14 | SRC_URI[sha256sum] = "e4bb9e08e12e7fa9f11fef544efc85e59ba34538593d9ad38148c7ca2bfbb566" |
| 15 | |
| 16 | inherit autotools gettext texinfo |
| 17 | |
| 18 | PACKAGECONFIG ??= "" |
| 19 | PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}" |
| 20 | |
| 21 | PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl" |
| 22 | |
| 23 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 24 | |
| 25 | # Let aclocal use the relative path for the m4 file rather than the |
| 26 | # absolute since tar has a lot of m4 files, otherwise there might |
| 27 | # be an "Argument list too long" error when it is built in a long/deep |
| 28 | # directory. |
| 29 | acpaths = "-I ./m4" |
| 30 | |
| 31 | do_install () { |
| 32 | autotools_do_install |
| 33 | ln -s tar ${D}${bindir}/gtar |
| 34 | } |
| 35 | |
| 36 | do_install_append_class-target() { |
| 37 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 38 | install -d ${D}${base_bindir} |
| 39 | mv ${D}${bindir}/tar ${D}${base_bindir}/tar |
| 40 | mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar |
| 41 | rmdir ${D}${bindir}/ |
| 42 | fi |
| 43 | } |
| 44 | |
| 45 | PACKAGES =+ "${PN}-rmt" |
| 46 | |
| 47 | FILES_${PN}-rmt = "${sbindir}/rmt*" |
| 48 | |
| 49 | inherit update-alternatives |
| 50 | |
| 51 | ALTERNATIVE_PRIORITY = "100" |
| 52 | |
| 53 | ALTERNATIVE_${PN} = "tar" |
| 54 | ALTERNATIVE_${PN}-rmt = "rmt" |
| 55 | ALTERNATIVE_${PN}_class-nativesdk = "" |
| 56 | ALTERNATIVE_${PN}-rmt_class-nativesdk = "" |
| 57 | |
| 58 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 59 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 60 | |
| 61 | PROVIDES_append_class-native = " tar-replacement-native" |
| 62 | NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" |
| 63 | |
| 64 | BBCLASSEXTEND = "native nativesdk" |