blob: 001db9e5e2ec9533d978acb0761bc84ba42a1bde [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2011 Intel Corporation
3#
4
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005PR = "r40"
6
7inherit packagegroup distro_features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008REQUIRED_DISTRO_FEATURES = "x11"
9
10PACKAGES = "${PN} ${PN}-utils"
11
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012# backwards compatibility for xserver-common
13VIRTUAL-RUNTIME_xserver_common ?= ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014
15# elsa, xserver-nodm-init
16VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
17
18SUMMARY = "X11 display server and basic utilities"
19RDEPENDS_${PN} = "\
20 ${PN}-xserver \
21 ${PN}-utils \
22 "
23
24SUMMARY_${PN}-utils = "X11 basic utilities and init"
25RDEPENDS_${PN}-utils = "\
26 ${VIRTUAL-RUNTIME_xserver_common} \
27 ${VIRTUAL-RUNTIME_graphical_init_manager} \
28 xauth \
29 xhost \
30 xset \
31 xrandr \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032 xmodmap \
33 xdpyinfo \
34 xinput-calibrator \
35 dbus-x11 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036 "