Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "GObject wrapper for libudev" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 2 | DESCRIPTION = "This library makes it much simpler to use libudev from programs \ |
| 3 | already using GObject. It also makes it possible to easily use libudev from \ |
| 4 | other programming languages, such as Javascript, because of GObject \ |
| 5 | introspection support." |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | HOMEPAGE = "https://wiki.gnome.org/Projects/libgudev" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/libgudev/issues" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 8 | SRC_URI[archive.sha256sum] = "61266ab1afc9d73dbc60a8b2af73e99d2fdff47d99544d085760e4fa667b5dd1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 10 | DEPENDS = "glib-2.0 glib-2.0-native udev" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RCONFLICTS:${PN} = "systemd (<= 220)" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 14 | LICENSE = "LGPL-2.1-only" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 16 | |
| 17 | inherit gnomebase gobject-introspection gtk-doc |
| 18 | |
Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 19 | SRC_URI += "file://0001-meson-Pass-export-dynamic-option-to-linker.patch" |
| 20 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 21 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 22 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 23 | |
| 24 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 25 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 26 | UPSTREAM_CHECK_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgudev/" |
| 27 | UPSTREAM_CHECK_REGEX = "(?P<pver>(\d+))" |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 28 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 29 | EXTRA_OEMESON += "-Dtests=disabled -Dvapi=disabled" |
| 30 | |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 31 | # This isn't a GNOME-style version do gnome_verdir fails. Just return the |
| 32 | # version as that is how the directory is structured. |
| 33 | def gnome_verdir(v): |
| 34 | return v |