Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "A collection of tools, libraries and tests for shader compilation" |
| 2 | DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \ |
| 3 | source code to SPIRV modules. It has been shipping in the Android NDK since version r12b." |
| 4 | SECTION = "graphics" |
| 5 | HOMEPAGE = "https://github.com/google/shaderc" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 9 | SRCREV = "4bbb646ddb3279c6a27e7aa0eb86c10c8add987b" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 10 | SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \ |
| 11 | file://0001-cmake-disable-building-external-dependencies.patch \ |
| 12 | file://0002-libshaderc_util-fix-glslang-header-file-location.patch \ |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 13 | file://0001-CMakeLists.txt-drop-OSDependent-OGLCompiler-from-lis.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 14 | " |
| 15 | UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$" |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake python3native pkgconfig |
| 19 | |
| 20 | DEPENDS = "spirv-headers spirv-tools glslang" |
| 21 | |
| 22 | EXTRA_OECMAKE = " \ |
| 23 | -DCMAKE_BUILD_TYPE=Release \ |
| 24 | -DBUILD_EXTERNAL=OFF \ |
| 25 | -DSHADERC_SKIP_TESTS=ON \ |
| 26 | -DSHADERC_SKIP_EXAMPLES=ON \ |
| 27 | -DSHADERC_SKIP_COPYRIGHT_CHECK=ON \ |
| 28 | " |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |