blob: 16d9c36eae8a9bc08ca38775cf66afe98b61902b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Generic XKB keymap library"
2DESCRIPTION = "libxkbcommon is a keymap compiler and support library which \
3processes a reduced subset of keymaps as defined by the XKB specification."
4HOMEPAGE = "http://www.xkbcommon.org"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e525ed9809e1f8a07cf4bce8b09e8b87"
6LICENSE = "MIT & MIT-style"
7
8DEPENDS = "util-macros flex-native bison-native"
9
10SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz"
11
12SRC_URI[md5sum] = "2d9ad3a46b317138b5e72a91cf105451"
13SRC_URI[sha256sum] = "57c3630cdc38fb4734cd57fa349e92244f5ae3862813e533cedbd86721a0b6f2"
14
15UPSTREAM_CHECK_URI = "http://xkbcommon.org/"
16
17inherit meson pkgconfig
18
19EXTRA_OEMESON = "-Denable-docs=false"
20
21PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)}"
22PACKAGECONFIG[x11] = "-Denable-x11=true,-Denable-x11=false,libxcb xkeyboard-config,"
23PACKAGECONFIG[wayland] = "-Denable-wayland=true,-Denable-wayland=false,wayland-native wayland wayland-protocols,"
24
25# Fix a following runtime error:
26# xkbcommon: ERROR: couldn't find a Compose file for locale "C"
27RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', 'libx11-compose-data', d)}"