blob: b3b43113204a5fa5e98e3b3f20535b64ecf2c68a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Geary is an email application built around conversations, for the GNOME 3 desktop."
2SECTION = "network"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2a2244d5a13871ad950c55877546a6a2"
5
6DEPENDS = " \
7 appstream-glib \
8 cairo \
9 enchant2 \
10 evolution-data-server \
11 folks \
12 gcr \
13 gmime \
14 gnome-online-accounts \
15 gsound \
16 gspell \
17 gtk+3 \
18 icu \
19 iso-codes \
20 json-glib \
21 libhandy \
22 libical \
23 libpeas \
24 libsecret \
25 libstemmer \
26 libxml2 \
27 sqlite3 \
28 webkitgtk \
29"
30
31RDEPENDS:${PN} = "gnome-keyring"
32
33inherit meson pkgconfig mime-xdg gtk-icon-cache gobject-introspection vala
34
35SRC_URI = " \
36 git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
37"
38
39S = "${WORKDIR}/git"
40SRCREV = "e561775c1580a9f60a726355b2b897bfc9cb3382"
41
42REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
43
44GIR_MESON_OPTION = ""
45EXTRA_OEMESON = "-Dprofile=release"
46
47PACKAGECONFIG[libunwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
48PACKAGECONFIG[tnef] = "-Dtnef=enabled,-Dtnef=disabled,libytnef"
49PACKAGECONFIG[valadoc] = "-Dvaladoc=enabled,-Dvaladoc=disabled"
50
51PACKAGECONFIG ??= ""
52
53FILES:${PN} += "${datadir}"
54