blob: 5081583d6361a34b6513ce9fecd552a5d5dd7151 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = " \
8 alsa-lib \
9 atk \
10 cairo \
11 fontconfig \
12 freetype \
13 gdk-pixbuf-native \
14 intltool-native \
15 libxslt-native \
16 gegl-native \
17 dbus-glib \
18 gtk+ \
19 babl \
20 gegl \
21 libmypaint \
22 mypaint-brushes-1.0 \
23 gexiv2 \
24 jpeg \
25 libmng \
26 libpng \
27 libexif \
28 tiff \
29 lcms \
30 poppler \
31 poppler-data \
32 jasper \
33 bzip2 \
34 libgudev \
35 libmng \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
37"
38DEPENDS:append:libc-musl = " libexecinfo"
39
40inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
41
42REQUIRED_DISTRO_FEATURES = "x11"
43
44SHPV = "${@gnome_verdir("${PV}")}"
45
46SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
47SRC_URI[sha256sum] = "88815daa76ed7d4277eeb353358bafa116cd2fcd2c861d95b95135c1d52b67dc"
48
49EXTRA_OECONF = "--disable-python \
50 --without-webkit \
51 --disable-check-update \
52 --without-wmf"
53
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000054EXTRA_OECONF:append:toolchain-clang:arm = " --disable-vector-icons"
Andrew Geissler595f6302022-01-24 19:11:47 +000055EXTRA_OECONF:append:toolchain-clang:riscv32 = " --disable-vector-icons"
56EXTRA_OECONF:append:toolchain-clang:mips = " --disable-vector-icons"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000057EXTRA_OECONF:append:toolchain-clang:x86 = " --disable-vector-icons"
Andrew Geissler595f6302022-01-24 19:11:47 +000058
59do_configure:append() {
60 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
61 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
62}
63
64do_compile:prepend() {
65 # Let native babl/gegl find their plugins
66 export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
67 export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
68}
69
70FILES:${PN} += "${datadir}/metainfo"
71
72RDEPENDS:${PN} += "mypaint-brushes-1.0"