blob: 7e254f52c727670d67f60fb6b2a313c8d64f7ae0 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNOME disk utility"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SECTION = "x11/gnome"
6
7DEPENDS = " \
8 gtk+3 \
9 libdvdread \
10 libcanberra \
11 libnotify \
12 libsecret \
13 libpwquality \
14 udisks2 \
15 libhandy \
16"
17
18GNOMEBASEBUILDCLASS = "meson"
19
20inherit gnomebase gsettings gtk-icon-cache gettext features_check mime-xdg
21
22REQUIRED_DISTRO_FEATURES = "x11 polkit"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
25
26# As soon as elogind is of interest this needs rework: meson option is combo
27PACKAGECONFIG[systemd] = "-Dlogind=libsystemd,-Dlogind=none,systemd"
28
29SRC_URI += " file://0001-build-fix-arguments-of-i18n.merge_file.patch"
30SRC_URI[archive.sha256sum] = "8743c98fd656062ef862933efe30c5be4c6b322ec02eee154ec70d08ed0895df"
31
32FILES:${PN} += " \
33 ${datadir}/metainfo \
34 ${datadir}/dbus-1 \
35"