blob: 30275c97e3d0c146912e1d2945edf41fc44e1e12 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNOME tweaks: Advanced options for GNOME 3 session"
2LICENSE = "GPLv3 & CC0-1.0"
3LIC_FILES_CHKSUM = " \
4 file://LICENSES/CC0-1.0;md5=65d3616852dbf7b1a6d4b53b00626032 \
5 file://LICENSES/GPL-3.0;md5=9eef91148a9b14ec7f9df333daebc746 \
6"
7
8DEPENDS = "libhandy"
9
10GNOMEBASEBUILDCLASS = "meson"
11
12inherit gnomebase gtk-icon-cache gobject-introspection features_check
13
14# same as gnome-shell
15REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
16
17# gobject-introspection is mandatory and cannot be configured
18REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
19GIR_MESON_OPTION = ""
20
21SRC_URI[archive.sha256sum] = "f95f3fe031b0b01c02f79a1659f889152d3772ae3e44df8403d1460ba5eec36a"
22SRC_URI += "file://0001-Make-python-path-configurable.patch"
23
24EXTRA_OEMESON = "-Dpython_site_dir=${PYTHON_SITEPACKAGES_DIR}"
25
26FILES:${PN} += " \
27 ${datadir}/metainfo \
28 ${PYTHON_SITEPACKAGES_DIR} \
29"
30
31RDEPENDS:${PN} += "gnome-shell python3-core python3-logging libhandy"