blob: 5b5ce5328aedb15960a400197e8a9a73f873a05c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Portable C library for multiline text editing"
2HOMEPAGE = "http://projects.gnome.org/gtksourceview/"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
6
7DEPENDS = "gtk+3 libxml2 intltool-native gnome-common-native glib-2.0-native"
8
9PNAME = "gtksourceview"
10
11S = "${WORKDIR}/${PNAME}-${PV}"
12
13GNOMEBASEBUILDCLASS = "meson"
14
15inherit gnomebase lib_package gettext features_check gtk-doc gobject-introspection vala
16
17REQUIRED_DISTRO_FEATURES = "x11"
18
19SRC_URI = "https://download.gnome.org/sources/gtksourceview/4.8/${PNAME}-${PV}.tar.xz"
20SRC_URI[sha256sum] = "842de7e5cb52000fd810e4be39cd9fe29ffa87477f15da85c18f7b82d45637cc"
21
22GIR_MESON_OPTION = 'gir'
23GTKDOC_MESON_OPTION = "gtk_doc"
24
25# Override the definition in meson.bbclass. The dependencies in mason.build are incomplete
26# and the recipe will not build with "-j 1". This fix is benign but should be reviewed when
27# updating versions.
28#
29meson_do_compile() {
30 bbnote "========== generating gtksourceview-gresources.h ========"
31 bbnote "PARALLEL_MAKE is ${PARALLEL_MAKE}"
32 ninja ${PARALLEL_MAKE} gtksourceview/gtksourceview-gresources.h
33 bbnote "========== compiling target all ========"
34 ninja ${PARALLEL_MAKE}
35}
36
37FILES:${PN} += "${datadir}/gtksourceview-4"