blob: 6c9e631e1164c4c2fc9e771c11118e3be5b52f28 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Window navigation construction toolkit"
2LICENSE = "LGPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5BPN = "libwnck"
6
7SECTION = "x11/libs"
8DEPENDS = "intltool-native gnome-common-native gtk+3 gdk-pixbuf-native libxres"
9
10PACKAGECONFIG ??= "startup-notification"
11PACKAGECONFIG[startup-notification] = "-Dstartup_notification=enabled,-Dstartup_notification=disabled,startup-notification"
12
13GNOMEBASEBUILDCLASS = "meson"
14GTKDOC_MESON_OPTION = "gtk_doc"
15GIR_MESON_ENABLE_FLAG = 'enabled'
16GIR_MESON_DISABLE_FLAG = 'disabled'
17
18inherit gnomebase gobject-introspection gtk-doc gettext features_check
19
20def gnome_verdir(v):
21 return oe.utils.trim_version(v, 1)
22
23SRC_URI[archive.sha256sum] = "03134fa114ef3fbe34075aa83678f58aa2debe9fcef4ea23c0779e28601d6611"
24
25# libxres means x11 only
26REQUIRED_DISTRO_FEATURES = "x11"