blob: 58479cf7b3c04e33e32d66c7c7a45409109871be [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SECTION = "x11/wm"
2SUMMARY = "Metacity is the boring window manager for the adult in you"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b4cce53560b8e619ffa7c830fb8761aa \
5 file://src/include/main.h;endline=24;md5=72148ede07a6dadd01de6a882d20a9ad"
6
7PE = "1"
8
9DEPENDS = " \
10 gdk-pixbuf-native \
11 gtk+3 \
12 gsettings-desktop-schemas \
13 startup-notification \
14 libcanberra \
15 libgtop \
16 libxres \
17 libxpresent \
18"
19
20
21# depends on startup-notification which depends on virtual/libx11
22REQUIRED_DISTRO_FEATURES = "x11"
23
24inherit gnomebase gsettings gettext upstream-version-is-even features_check
25
26SRC_URI[archive.sha256sum] = "d89d679dcfed9b5eef18f06e2dcb33a7ab543d53b358fa89ce65593c231eeebc"
27SRC_URI += "file://0001-drop-zenity-detection.patch"
28
29PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
30# enable as neccessary until new warnings are dealt with
31PACKAGECONFIG[werror] = "--enable-Werror,--disable-Werror,,"
32
33FILES:${PN} += " \
34 ${datadir}/themes \
35 ${datadir}/gnome-control-center \
36 ${datadir}/gnome\
37"
38
39RDEPENDS:${PN} += "gsettings-desktop-schemas"