blob: 544b6138fc586f7d527e83fec774946bf57e2677 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
2It converts audio files among various standard audio file formats \
3and can apply different effects and filters to the audio data."
4HOMEPAGE = "http://sox.sourceforge.net"
5SECTION = "audio"
6
7DEPENDS = "libpng ffmpeg libsndfile1"
8
Brad Bishop316dfdd2018-06-25 12:45:53 -04009PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)} \
10 magic \
11"
12PACKAGECONFIG[pulseaudio] = "--with-pulseaudio=dyn,--with-pulseaudio=no,pulseaudio,"
13PACKAGECONFIG[alsa] = "--with-alsa=dyn,--with-alsa=no,alsa-lib,"
14PACKAGECONFIG[wavpack] = "--with-wavpack=dyn,--with-wavpack=no,wavpack,"
15PACKAGECONFIG[flac] = "--with-flac=dyn,--with-flac=no,flac,"
16PACKAGECONFIG[amrwb] = "--with-amrwb=dyn,--with-amrwb=no,opencore-amr,"
17PACKAGECONFIG[amrnb] = "--with-amrnb=dyn,--with-amrnb=no,opencore-amr,"
18PACKAGECONFIG[oggvorbis] = "--with-oggvorbis=dyn,--with-oggvorbis=no,libvorbis"
19PACKAGECONFIG[opus] = "--with-opus=dyn,--with-opus=no,opusfile"
20PACKAGECONFIG[magic] = "--with-magic,--without-magic,file,"
21PACKAGECONFIG[mad] = "--with-mad,--without-mad,libmad,"
22PACKAGECONFIG[id3tag] = "--with-id3tag,--without-id3tag,libid3tag,"
23PACKAGECONFIG[lame] = "--with-lame,--without-lame,lame,"
24PACKAGECONFIG[ao] = "--with-ao,--without-ao,libao,"
25
26LICENSE = "GPLv2 & LGPLv2.1"
27LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe \
28 file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
29
30SRC_URI = "${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz \
31 file://0001-remove-the-error-line-and-live-without-file-type-det.patch \
32 file://0001-Update-exported-symbol-list.patch \
33 "
34SRC_URI[md5sum] = "d04fba2d9245e661f245de0577f48a33"
35SRC_URI[sha256sum] = "b45f598643ffbd8e363ff24d61166ccec4836fea6d3888881b8df53e3bb55f6c"
36
37inherit autotools pkgconfig
Andrew Geissler32b11992021-03-31 13:37:05 -050038
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000039EXCLUDE_FROM_WORLD = "${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "0", "1", d)}"