blob: bc54ea9fe56d7391822a801cdb0d7acaea16bc0b [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
5HOMEPAGE = "https://github.com/graeme-hill/crossguid"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
8DEPENDS += "util-linux"
9
10SRCREV = "5b45cdd9a56ca9da35ee0f8845cb4e2603d245dc"
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https;branch=master"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050012
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17do_install() {
18 install -D -m 0644 ${B}/libxg.a ${D}${libdir}/libxg.a
19 install -D -m 0644 ${S}/Guid.hpp ${D}${includedir}/Guid.hpp
20}