blob: df496c36835218a86ac6065cc8aff1d4ad3f89e8 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
6
7inherit autotools gettext systemd gsettings pkgconfig python3native gtk-icon-cache
8
9SRC_URI = " \
10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
11 file://0001-Search-for-cython3.patch \
12 file://0002-fix-fail-to-enable-bluetooth.patch \
13"
14SRC_URI[sha256sum] = "6edd791da6afd8f610ffb08d5138cfcf50e6257ad30efad686287f3a2be106e9"
15
16EXTRA_OECONF = " \
17 --disable-appindicator \
18 --disable-runtime-deps-check \
19 --disable-schemas-compile \
20"
21
22SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service"
23SYSTEMD_AUTO_ENABLE:${PN} = "disable"
24
25RRECOMENDS_${PN} += "adwaita-icon-theme"
26RDEPENDS:${PN} += " \
27 python3-core \
28 python3-dbus \
29 packagegroup-tools-bluetooth \
30"
31
32PACKAGECONFIG ??= "thunar"
33PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto"
34
35FILES:${PN} += " \
36 ${datadir}/dbus-1 \
37 ${datadir}/Thunar \
38 ${systemd_user_unitdir} \
39 ${exec_prefix}${systemd_system_unitdir} \
40 ${PYTHON_SITEPACKAGES_DIR} \
41"
42
43FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"
44
45# In code, path to python is a variable that is replaced with path to native version of it
46# during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3.
47# Replace it with #!/usr/bin/env python3
48do_install:append() {
49 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
50 ${D}${prefix}/libexec/blueman-mechanism \
51 ${D}${bindir}/blueman-adapters \
52 ${D}${bindir}/blueman-applet \
53 ${D}${bindir}/blueman-manager \
54 ${D}${bindir}/blueman-sendto \
55 ${D}${bindir}/blueman-services \
56 ${D}${bindir}/blueman-tray
57}