blob: 91df1547d955e2d71d8df62dde55892edc1de5c9 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Netfilter Tables userspace utillites"
2SECTION = "net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
5
6DEPENDS = "libmnl libnftnl bison-native \
7 ${@bb.utils.contains('PACKAGECONFIG', 'mini-gmp', '', 'gmp', d)}"
8
9# Ensure we reject the 0.099 version by matching at least two dots
10UPSTREAM_CHECK_REGEX = "nftables-(?P<pver>\d+(\.\d+){2,}).tar.bz2"
11
12SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
13SRC_URI[sha256sum] = "3ceeba625818e81a0be293e9dd486c3ef799ebd92165270f1e57e9a201efa423"
14
15inherit autotools manpages pkgconfig
16
17PACKAGECONFIG ??= "python readline json"
18PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
19PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
20PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
21PACKAGECONFIG[python] = "--enable-python --with-python-bin=${PYTHON}, --with-python-bin="", python3"
22PACKAGECONFIG[readline] = "--with-cli=readline, --without-cli, readline"
23PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
24
25inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
26
27RRECOMMENDS:${PN} += "kernel-module-nf-tables"
28
29PACKAGES =+ "${PN}-python"
30FILES:${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
31RDEPENDS:${PN}-python = "python3-core python3-json ${PN}"