blob: ca404ebc878cb7554d5e5221b9da0d4a837c5c9f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Full-featured IRC plugin: multi-servers, proxy support, IPv6, SASL authentication, nicklist, DCC, and many other features"
2HOMEPAE = "https://weechat.org/"
3SECTION = "net"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
6
7DEPENDS = "openssl zlib icu libgcrypt gnutls curl aspell"
8
9SRC_URI = "https://weechat.org/files/src/weechat-${PV}.tar.xz \
10 file://0001-use-pkg-config-for-gcrypt-instead.patch \
11 "
12
13SRC_URI[sha256sum] = "7cd3dcc7029e888de49e13ebbcc3749586ff59c9d97f89f5eeb611067c7bb94c"
14
15inherit cmake pkgconfig
16
17PACKAGECONFIG ??= " ncurses python"
18PACKAGECONFIG[ncurses] = "-DENABLE_NCURSES=ON,-DENABLE_NCURSES=OFF,ncurses"
19PACKAGECONFIG[python] = "-DENABLE_PYTHON=ON,-DENABLE_PYTHON=OFF,python3,python3"
20
21EXTRA_OECMAKE:append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON"
22
23do_configure:prepend(){
24 # Make sure we get dependencies from recipe-sysroot
25 sed -i -e 's# /usr/bin# ${RECIPE_SYSROOT}/${bindir}/#g' ${S}/cmake/FindPerl.cmake
26 sed -i -e 's# /usr/local/bin##g' ${S}/cmake/FindPerl.cmake
27 sed -i -e 's# /usr/pkg/bin##g' ${S}/cmake/FindPerl.cmake
28}
29
30do_install:append(){
31 rm -rf ${D}/${datadir}
32}
33