blob: 1017f16adde9a164f88e587db6b36a6f6e4f67d2 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Dovecot is an open source IMAP and POP3 email server"
2HOMEPAGE = "https://www.dovecot.org/"
3DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory."
4SECTION = "mail"
5LICENSE = "LGPLv2.1 & MIT"
Andrew Geisslereef63862021-01-29 15:58:13 -06006LIC_FILES_CHKSUM = "file://COPYING;md5=2956560272e5b31d9d64f03111732048"
Brad Bishopc342db32019-05-15 21:57:59 -04007
Andrew Geisslereef63862021-01-29 15:58:13 -06008SRC_URI = "http://dovecot.org/releases/2.3/dovecot-${PV}.tar.gz \
Brad Bishopc342db32019-05-15 21:57:59 -04009 file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \
10 file://dovecot.service \
11 file://dovecot.socket \
Andrew Geisslereef63862021-01-29 15:58:13 -060012 file://0001-not-check-pandoc.patch \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070013 file://0001-m4-Check-for-libunwind-instead-of-libunwind-generic.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040014 "
15
Andrew Geissler32b11992021-03-31 13:37:05 -050016SRC_URI[md5sum] = "2f03532cec3280ae45a101a7a55ccef5"
17SRC_URI[sha256sum] = "c8b3d7f3af1e558a3ff0f970309d4013a4d3ce136f8c02a53a3b05f345b9a34a"
Brad Bishopc342db32019-05-15 21:57:59 -040018
Andrew Geisslereef63862021-01-29 15:58:13 -060019DEPENDS = "openssl xz zlib bzip2 libcap icu libtirpc bison-native"
Brad Bishopc342db32019-05-15 21:57:59 -040020CFLAGS += "-I${STAGING_INCDIR}/tirpc"
21LDFLAGS += "-ltirpc"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023inherit autotools pkgconfig systemd useradd gettext
Brad Bishopc342db32019-05-15 21:57:59 -040024
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ldap pam', d)}"
26
27PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
28PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
29PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
30
31# From native build in armv7a-hf/eglibc
32CACHED_CONFIGUREVARS += "i_cv_signed_size_t=no \
33 i_cv_gmtime_max_time_t=32 \
34 i_cv_signed_time_t=yes \
35 i_cv_mmap_plays_with_write=yes \
36 i_cv_fd_passing=yes \
37 i_cv_c99_vsnprintf=yes \
38 lib_cv___va_copy=yes \
39 lib_cv_va_copy=yes \
40 lib_cv_va_val_copy=yes \
41 "
42
43# hardcode epoll() to avoid running unsafe tests
44# BSD needs kqueue and uclibc poll()
45EXTRA_OECONF = " --with-ioloop=epoll \
46 --with-systemdsystemunitdir=${systemd_unitdir}/system"
47
Andrew Geissler4b7c1152020-11-30 19:55:29 -060048# Uses hidden symbols
49# libssl_iostream_openssl.so: undefined reference to `ssl_iostream_handshake'
50LTO = ""
51
Brad Bishopc342db32019-05-15 21:57:59 -040052SYSTEMD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050053SYSTEMD_SERVICE:${PN} = "dovecot.service dovecot.socket"
Brad Bishopc342db32019-05-15 21:57:59 -040054SYSTEMD_AUTO_ENABLE = "disable"
55
Patrick Williams213cb262021-08-07 19:21:33 -050056do_install:append () {
Brad Bishopc342db32019-05-15 21:57:59 -040057 install -d 755 ${D}/etc/dovecot
58 touch 644 ${D}/etc/dovecot/dovecot.conf
59 install -m 0644 ${WORKDIR}/dovecot.service ${D}${systemd_unitdir}/system
60 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/dovecot.service
61 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/dovecot.service
62}
63
64USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050065USERADD_PARAM:${PN} = "-r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovecot dovecot; \
Brad Bishopc342db32019-05-15 21:57:59 -040066 -r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovenull dovenull"
Patrick Williams213cb262021-08-07 19:21:33 -050067GROUPADD_PARAM:${PN} = "-f -r dovecot;-f -r dovenull"
Brad Bishopc342db32019-05-15 21:57:59 -040068
Patrick Williams213cb262021-08-07 19:21:33 -050069FILES:${PN} += "${libdir}/dovecot/*plugin.so \
Brad Bishopc342db32019-05-15 21:57:59 -040070 ${libdir}/dovecot/libfs_compress.so \
71 ${libdir}/dovecot/libssl_iostream_openssl.so"
Patrick Williams213cb262021-08-07 19:21:33 -050072FILES:${PN}-staticdev += "${libdir}/dovecot/*/*.a"
73FILES:${PN}-dev += "${libdir}/dovecot/libdovecot*.so"
74FILES:${PN}-dbg += "${libdir}/dovecot/*/.debug"
Andrew Geissler69721092021-07-23 12:57:00 -040075
76# CVE-2016-4983 affects only postinstall script on specific distribution
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000077CVE_CHECK_IGNORE += "CVE-2016-4983"