blob: 352d2d24261273cd59131cf182b4a9c7065f756e [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A library for deep-packet inspection."
2DESCRIPTION = "nDPI is an open source LGPLv3 library for deep-packet \
3inspection. Based on OpenDPI it includes ntop extensions"
4
5SECTION = "libdevel"
6DEPENDS = "libpcap json-c"
7RDEPENDS:${PN} += " libpcap"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
10
11SRCREV = "8b5c6af71b562549f8416b31803daae223e09f46"
12SRC_URI = "git://github.com/ntop/nDPI.git;branch=4.2-stable;protocol=https \
13 file://0001-autogen.sh-not-generate-configure.patch \
14 "
15
16S = "${WORKDIR}/git"
17
18inherit autotools-brokensep pkgconfig
19
20CPPFLAGS += "${SELECTED_OPTIMIZATION}"
21
22do_configure:prepend() {
23 ${S}/autogen.sh
24}
25
26EXTRA_OEMAKE = " \
27 libdir=${libdir} \
28"