blob: 6ee2651afe75800517b187a9488505ced91a3f88 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Wireless daemon for Linux"
2HOMEPAGE = "https://iwd.wiki.kernel.org/"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
5
6DEPENDS = "ell"
7
8SRC_URI = "https://www.kernel.org/pub/linux/network/wireless/${BP}.tar.xz \
9 file://0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch \
10 "
11SRC_URI[sha256sum] = "61b5e48380cd3a6d0529f725eb6974157f1410af165f5d266b87add0bf395224"
12
13inherit autotools manpages pkgconfig python3native systemd
14
15PACKAGECONFIG ??= " \
16 client \
17 monitor \
18 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
19"
20PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
21PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
22PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
23PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
24PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
25PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
26
27EXTRA_OECONF = "--enable-external-ell"
28
29SYSTEMD_SERVICE:${PN} = " \
30 iwd.service \
31 ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
32"
33
34do_configure:prepend() {
35 install -d ${S}/build-aux
36}
37
38do_install:append() {
39 # If client and monitor are disabled, bindir is empty, causing a QA error
40 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
41}
42
43FILES:${PN} += " \
44 ${datadir}/dbus-1 \
45 ${nonarch_libdir}/modules-load.d \
46 ${systemd_unitdir}/network \
47"
48
49RDEPENDS:${PN} = "dbus"
50
51RRECOMMENDS:${PN} = "\
52 kernel-module-pkcs7-message \
53 kernel-module-pkcs8-key-parser \
54 kernel-module-x509-key-parser \
55"