blob: b5a6ac29c336923b93e58280e10628c911c48f47 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Paho MQTT - C++ libraries for the MQTT and MQTT-SN protocols"
2DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
3HOMEPAGE = "http://www.eclipse.org/paho/"
4SECTION = "console/network"
5LICENSE = "EPL-1.0 | EDL-1.0"
6
7LIC_FILES_CHKSUM = " \
8 file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
9 file://epl-v10;md5=659c8e92a40b6df1d9e3dccf5ae45a08 \
10 file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \
11 file://about.html;md5=dcde438d73cf42393da9d40fabc0c9bc \
12"
13
14SRC_URI = "git://github.com/eclipse/paho.mqtt.cpp;protocol=http;branch=master;protocol=https"
15
16SRCREV = "33921c8b68b351828650c36816e7ecf936764379"
17
18DEPENDS = "openssl paho-mqtt-c"
19
20S = "${WORKDIR}/git"
21
22inherit cmake
23
24EXTRA_OECMAKE += "-DPAHO_WITH_SSL=ON"