blob: 36004c53d6ee4eda22d314b6c1af8c9ba26b7af4 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Cap'n Proto serialization/RPC system"
2DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. "
3HOMEPAGE = "https://github.com/sandstorm-io/capnproto"
4SECTION = "console/tools"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9"
7
8SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV};protocol=https \
9 "
10SRCREV = "b49431c48d40490ef979247d308af63345376cee"
11
12S = "${WORKDIR}/git/c++"
13
14inherit cmake
15
16CXXFLAGS:append:mips = " -latomic"
17CXXFLAGS:append:riscv32 = " -latomic"
18
19EXTRA_OECMAKE += "\
20 -DBUILD_TESTING=OFF \
21"
22
23FILES:${PN}-compiler = "${bindir}"
24
25PACKAGE_BEFORE_PN = "${PN}-compiler"
26RDEPENDS:${PN}-dev += "${PN}-compiler"
27
28BBCLASSEXTEND = "native nativesdk"