blob: 99e09bfc62ec360f8c5f46171b0504ef485a27b7 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "curses-based interface to GDB"
2DESCRIPTION = "cgdb is a lightweight curses (terminal-based) interface to the GNU Debugger (GDB)."
3HOMEPAGE = "http://cgdb.github.io/"
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8DEPENDS = "flex-native readline ncurses"
9
10inherit autotools texinfo
11
12SRC_URI = "http://cgdb.me/files/${BP}.tar.gz"
13SRC_URI[sha256sum] = "0d38b524d377257b106bad6d856d8ae3304140e1ee24085343e6ddf1b65811f1"
14
15CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes ac_cv_rl_version=6.2 ac_cv_file__proc_self_status=yes"
16EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} \
17 --with-ncurses=${STAGING_LIBDIR}"
18
19RDEPENDS:${PN} = "gdb"