blob: a69c5c7e585acc8f3bad730c552b04183fa9e6a2 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588"
6
7SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1;protocol=https \
8 "
9
10SRCREV = "4f8fba14066156b73f1189a2b8bd568bde5284c5"
11
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
17
18# nlohmann-json is a header only C++ library, so the main package will be empty.
19
20RDEPENDS:${PN}-dev = ""
21
22BBCLASSEXTEND = "native nativesdk"
23
24# other packages commonly reference the file directly as "json.hpp"
25# create symlink to allow this usage
26do_install:append() {
27 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
28}