blob: b09c46a66b9c2f5ef061e25868421835dfbea2e0 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Light-weight C++ XML Processing Library"
2DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \
3DOM-like interface with rich traversal/modification capabilities, \
4an extremely fast XML parser which constructs the DOM tree from \
5n XML file/buffer, and an XPath 1.0 implementation for complex \
6data-driven tree queries."
7HOMEPAGE = "https://pugixml.org/"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=d11b640daff611273752ec136394347c"
11
12SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
13SRC_URI[sha256sum] = "fd6922a4448ec2f3eb9db415d10a49660e5d84ce20ce66b8a07e72ffc84270a7"
14
15UPSTREAM_CHECK_URI = "https://github.com/zeux/${BPN}/releases"
16
17inherit cmake
18
19EXTRA_OECMAKE += "-DBUILD_PKGCONFIG=ON \
20 -DBUILD_SHARED_LIBS=ON \
21 -DCMAKE_BUILD_TYPE=Release \
22 "
23
24BBCLASSEXTEND = "native nativesdk"