blob: 05d3a1e239538c77a359e9fca83775cd829e90a5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001#
2# Copyright (C) 2014 - 2017 Wind River Systems, Inc.
3#
4SUMMARY = "CFEngine is an IT infrastructure automation framework"
5
6DESCRIPTION = "CFEngine is an IT infrastructure automation framework \
7that helps engineers, system administrators and other stakeholders \
8in an IT system to manage and understand IT infrastructure throughout \
9its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit."
10
11HOMEPAGE = "http://cfengine.com"
12
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013SKIP_RECIPE[cfengine] ?= "Needs porting to openssl 3.x"
Andrew Geisslereff27472021-10-29 15:35:00 -050014
Andrew Geissler82c905d2020-04-13 13:39:40 -050015LICENSE = "GPLv3"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=233aa25e53983237cf0bd4c238af255f"
17
18DEPENDS = "attr tokyocabinet bison-native"
19
20SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz \
21 file://set-path-of-default-config-file.patch \
22 "
23SRC_URI[md5sum] = "d4dabfa46d8afa151be5610f184354e7"
24SRC_URI[sha256sum] = "fa53e137f850eb268a8e7ae4578b5db5dc383656341f5053dc1a353ed0288265"
25
26inherit autotools-brokensep systemd
27
28export EXPLICIT_VERSION="${PV}"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030SYSTEMD_SERVICE:${PN} = "cfengine3.service cf-apache.service cf-hub.service cf-postgres.service \
Andrew Geissler82c905d2020-04-13 13:39:40 -050031 cf-runalerts.service cf-execd.service \
32 cf-monitord.service cf-serverd.service \
33"
Patrick Williams213cb262021-08-07 19:21:33 -050034SYSTEMD_AUTO_ENABLE:${PN} = "disable"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035
36PACKAGECONFIG ??= "libpcre openssl \
37 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \
38"
39PACKAGECONFIG[libxml2] = "--with-libxml2=yes,--with-libxml2=no,libxml2,"
40PACKAGECONFIG[mysql] = "--with-mysql=yes,--with-mysql=no,mysql,"
41PACKAGECONFIG[postgresql] = "--with-postgresql=yes,--with-postgresql=no,postgresql,"
42PACKAGECONFIG[acl] = "--with-libacl=yes,--with-libacl=no,acl,"
43PACKAGECONFIG[libvirt] = "--with-libvirt=yes,--with-libvirt=no,libvirt,"
44PACKAGECONFIG[libpcre] = "--with-pcre=yes,--with-pcre=no,libpcre,"
45PACKAGECONFIG[openssl] = "--with-openssl=yes,--with-openssl=no,openssl,"
46PACKAGECONFIG[pam] = "--with-pam=yes,--with-pam=no,libpam,"
47PACKAGECONFIG[libyaml] = "--with-libyaml,--without-libyaml,libyaml,"
48PACKAGECONFIG[systemd] = "--with-systemd-service=${systemd_system_unitdir},--without-systemd-service"
49PACKAGECONFIG[libcurl] = "--with-libcurl,--without-libcurl,curl,"
50
51EXTRA_OECONF = "hw_cv_func_va_copy=yes --with-init-script=${sysconfdir}/init.d --with-tokyocabinet"
52
Patrick Williams213cb262021-08-07 19:21:33 -050053do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050054 install -d ${D}${localstatedir}/${BPN}/bin
55 for f in `ls ${D}${bindir}`; do
56 ln -s ${bindir}/`basename $f` ${D}${localstatedir}/${BPN}/bin/
57 done
58
59 install -d ${D}${sysconfdir}/default
60 cat << EOF > ${D}${sysconfdir}/default/cfengine3
61RUN_CF_SERVERD=1
62RUN_CF_EXECD=1
63RUN_CF_MONITORD=1
64RUN_CF_HUB=0
65EOF
66
67 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
68 install -m 0755 -D ${D}${sysconfdir}/init.d/cfengine3 ${D}${datadir}/${BPN}/cfengine3
69 sed -i -e 's#/etc/init.d#${datadir}/${BPN}#' ${D}${systemd_system_unitdir}/*.service
70 fi
71 rm -rf ${D}${datadir}/cfengine/modules/packages/zypper
72}
73
Patrick Williams213cb262021-08-07 19:21:33 -050074RDEPENDS:${PN} += "${BPN}-masterfiles"