blob: 95df28ef2be2c1d9ffbd0576c6bf9f3dc65d99fc [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Duktape embeddable Javascript engine"
2DESCRIPTION = "Duktape is an embeddable Javascript engine, with a focus on portability and compact footprint."
3HOMEPAGE = "https://duktape.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c83446610de1f63c7ca60cfcc82dec9d"
6
7SRC_URI = "https://duktape.org/duktape-${PV}.tar.xz \
8 file://0001-Support-makefile-variables.patch \
9"
10SRC_URI[md5sum] = "01ee8ecf3dd5c6504543c8679661bb20"
11SRC_URI[sha256sum] = "96f4a05a6c84590e53b18c59bb776aaba80a205afbbd92b82be609ba7fe75fa7"
12
13do_compile () {
14 oe_runmake -f Makefile.sharedlibrary INSTALL_PREFIX="${prefix}" DESTDIR="${D}"
15}
16
17do_install () {
18 oe_runmake -f Makefile.sharedlibrary INSTALL_PREFIX="${prefix}" DESTDIR="${D}" install
19 # libduktaped is identical to libduktape but has an hard-coded -g build flags, remove it
20 rm -f ${D}${libdir}/libduktaped.so*
21}