blob: 087b69faae39d7003ec4ae9a71688eb1d79f90dc [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Gnuplot is a portable command-line driven graphing utility"
2DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
3(text or binary) and function plotting utility."
4HOMEPAGE = "http://www.gnuplot.info/"
5SECTION = "console/scientific"
6LICENSE = "gnuplot"
7LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
8DEPENDS = "${BPN}-native virtual/libx11 gd readline"
9
10inherit autotools features_check
11# depends on virtual/libx11
12REQUIRED_DISTRO_FEATURES = "x11"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${PV}/${BP}.tar.gz;name=archive \
15 http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \
16 file://gnuplot.desktop \
17 file://gnuplot.png \
18 "
19SRC_URI:append:class-target = " \
20 file://0002-do-not-build-demos.patch \
21 file://0003-Use-native-tools-to-build-docs.patch \
22 file://0004-Add-configure-option-to-find-qt5-native-tools.patch \
23"
24
25SRC_URI[archive.sha256sum] = "51f89bbab90f96d3543f95235368d188eb1e26eda296912256abcd3535bd4d84"
26SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132"
27
28# for building docs (they deserve it) we need *doc2* tools native
29BBCLASSEXTEND = "native"
30DEPENDS:class-native = "readline-native"
31PACKAGECONFIG:class-native = ""
32
33SRC_URI:append:class-native = " file://0001-reduce-build-to-conversion-tools-for-native-build.patch"
34
35do_install:class-native() {
36 install -d ${D}${bindir}
37 install ${B}/docs/*doc* ${D}${bindir}
38 rm ${D}${bindir}/*.o
39}
40
41PACKAGECONFIG ??= "cairo"
42PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango"
43PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
44PACKAGECONFIG[qt5] = "--with-qt --with-qt5nativesysroot=${STAGING_DIR_NATIVE},--without-qt,qtbase-native qtbase qtsvg qttools-native"
45
46EXTRA_OECONF = " \
47 --with-readline=${STAGING_LIBDIR}/.. \
48 -disable-wxwidgets \
49"
50
51do_compile:prepend() {
52 install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
53}
54
55do_install:append:class-target() {
56 install -d ${D}${datadir}/applications/
57 install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
58 install -d ${D}${datadir}/pixmaps/
59 install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
60}
61
62PACKAGES =+ "${PN}-x11"
63
64RPROVIDES:${PN}-dbg += "${PN}-x11-dbg"
65
66DESCRIPTION:${PN}-x11 = "X11 display terminal for Gnuplot."
67SECTION:${PN}-x11 = "x11/scientific"
68FILES:${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
69
70FILES:${PN} += "${datadir}/texmf"