blob: fd4e31f3b5d05e5b1e4d58a567d8bd5c580afdd1 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A top utility for I/O"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=48e7be78bd2671d08c9c3bad71f1cfaa"
4
5DEPENDS = "ncurses"
6
7SRC_URI = "https://github.com/Tomas-M/iotop/releases/download/v1.21/iotop-1.21.tar.xz"
8SRC_URI[sha256sum] = "7b4862ebc93909a3f800193140ca2464e926291a9c873b50dc31fa77e6d9383e"
9UPSTREAM_CHECK_URI = "https://github.com/Tomas-M/iotop/releases"
10
11inherit pkgconfig
12
13EXTRA_OEMAKE = "V=1 STRIP=true"
14# Fixes llvm-bc70b5.o: can't link soft-float modules with double-float modules
15EXTRA_OEMAKE:append:toolchain-clang:riscv64 = " NO_FLTO=1"
16EXTRA_OEMAKE:append:toolchain-clang:riscv32 = " NO_FLTO=1"
17
18# Workaround BFD linker crash with clang on arm
19# revisit when upgrading binutils and see if its fixed
20LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld"
21
22do_install() {
23 oe_runmake install DESTDIR=${D}
24}