blob: 61f159c5740d97f1b136839a0566d4a8e3d83aa3 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Utilities to collect and visualise system statistics"
2HOMEPAGE = "http://www.i-scream.org/libstatgrab/"
3
4LICENSE = "GPL-2.0+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9PACKAGES:prepend = "statgrab statgrab-dbg saidar saidar-dbg ${PN}-mrtg "
10
11# don't use the git tag unless docbooc2x is available to build the manpages
12SRC_URI = "https://github.com/libstatgrab/libstatgrab/releases/download/LIBSTATGRAB_0_92_1/libstatgrab-${PV}.tar.gz \
13 "
14SRC_URI[sha256sum] = "5688aa4a685547d7174a8a373ea9d8ee927e766e3cc302bdee34523c2c5d6c11"
15
16UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
17
18# Perl5 is for tests only
19EXTRA_OECONF = "--without-perl5 --with-mnttab=/proc/mounts"
20
21# use with caution - default properties are configured to trace
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[log4cplus] = "--with-log4cplus,--without-log4cplus,log4cplus"
24PACKAGECONFIG[logging] = "--enable-logging,--disable-logging,"
25
26inherit autotools pkgconfig
27
28FILES:statgrab = "${bindir}/statgrab"
29FILES:statgrab-dbg = "${bindir}/.debug/statgrab"
30FILES:saidar = "${bindir}/saidar"
31FILES:saidar-dbg = "${bindir}/.debug/saidar"
32FILES:${PN}-mrtg = "${bindir}/statgrab-make-mrtg-config ${bindir}/statgrab-make-mrtg-index"
33RDEPENDS:${PN}-mrtg:append = " perl statgrab"