blob: 48a7701db7d2f053be47c06a49a0e62e38f9ce54 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A library to help create and query binary XML blobs"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
4
5SRC_URI = "git://github.com/hughsie/libxmlb.git;branch=main;protocol=https \
6 file://run-ptest \
7 "
8SRCREV = "dc96ba2327bb1f408909b2cd7fb4ecc318e8165a"
9S = "${WORKDIR}/git"
10
11inherit gobject-introspection gtk-doc meson ptest-gnome lib_package
12
13PACKAGECONFIG ??= "\
14 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
15"
16PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
17
18GTKDOC_MESON_OPTION = "gtkdoc"
19
20FILES:${PN}-bin += "${libexecdir}/*"