blob: 0c05c60eeeb32334d1b68dad8cb6756b18d9aeba [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A thin layer of graphic data types"
2HOMEPAGE = "http://ebassi.github.io/graphene/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a7d871d9e23c450c421a85bb2819f648"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8inherit gnomebase gobject-introspection gtk-doc
9
10SRC_URI[archive.sha256sum] = "80ae57723e4608e6875626a88aaa6f56dd25df75024bd16e9d77e718c3560b25"
11
12# gtk4 & mutter 41.0 requires graphene build with introspection
13PACKAGECONFIG ?= "introspection"
14PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled,"
15
16GTKDOC_MESON_OPTION = "gtk_doc"
17
18EXTRA_OEMESON = "-Dinstalled_tests=false"
19
20FILES:${PN} += "${libdir}/graphene-1.0"
21
22BBCLASSEXTEND = "native nativesdk"