blob: 57232f8d5fcd76208044f653eae14fbdd7d0833a [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Proxy for UDP/TCP debug connections"
2DESCRIPTION = "The agent-proxy will forward tcp or udp connections as well as allow for script multiplexing of terminal sessions."
3HOMEPAGE = "http://kgdb.wiki.kernel.org/"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
6
7SECTION = "devel"
8
9EXTRA_OEMAKE = "'CC=${CC}'"
10
Brad Bishopb809eb92019-09-18 06:27:43 -040011SRCREV = "468fe4c31e6c62c9bbb328b06ba71eaf7be0b76a"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git;protocol=git;branch=master \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://0001-Makefile-Add-LDFLAGS-variable.patch \
15"
16
17BBCLASSEXTEND = "native nativesdk"
18
19S = "${WORKDIR}/git"
20
21do_install () {
22 install -d ${D}${bindir}
23 install -m 0755 agent-proxy ${D}${bindir}
24}