blob: 4641b0181aef246b0614915c7275f2998b2eb9e2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require dfu-util_${PV}.bb
2
Andrew Geisslereef63862021-01-29 15:58:13 -06003inherit deploy native
Patrick Williamsb48b7b42016-08-17 15:04:38 -05004
5DEPENDS = "libusb1-native"
6
Brad Bishopdec060e2019-09-23 08:01:31 -04007PACKAGECONFIG ??= ""
8
9PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011do_deploy() {
Brad Bishopdec060e2019-09-23 08:01:31 -040012 install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 rm -f ${DEPLOYDIR}/dfu-util
14 ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015}
Brad Bishopdec060e2019-09-23 08:01:31 -040016
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017addtask deploy before do_package after do_install
Brad Bishope42b3e32020-01-15 22:08:42 -050018
Brad Bishope42b3e32020-01-15 22:08:42 -050019# cleandirs should possibly be in deploy.bbclass but we need it
20do_deploy[cleandirs] = "${DEPLOYDIR}"
21# clear stamp-extra-info since MACHINE_ARCH is normally put there by
22# deploy.bbclass
23do_deploy[stamp-extra-info] = ""
24