blob: cac2b4fd61fe1ede9bbadb254b474bcba7657ced [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "read temperature sensors in a 1-Wire net"
2SECTION = "util"
3DEPENDS = "libusb1"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0"
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007SRC_URI = "git://github.com/bcl/digitemp;branch=master;protocol=https"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008
Brad Bishopb809eb92019-09-18 06:27:43 -04009SRCREV = "a162e63aad35358aab325388f3d5e88121606419"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010
11S = "${WORKDIR}/git"
12
13EXTRA_OEMAKE = "ds9097 ds9097u \
14 SYSTYPE='Linux' \
15"
16do_configure() {
17 rm -f digitemp_*
18}
19
20do_install() {
21 install -d ${D}${sbindir}
22 install -m 0755 digitemp_* ${D}${sbindir}
23}