blob: c53dd3890129e8fdda790a854f5820fa46d31f0f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "open-source formatting library for C++"
2DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
3HOMEPAGE = "https://fmt.dev"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=af88d758f75f3c5c48a967501f24384b"
6
7SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https"
8SRCREV = "b6f4ceaed0a0a24ccf575fab6c56dd50ccf6f1a9"
9
10S = "${WORKDIR}/git"
11
12inherit cmake
13inherit ptest
14
15EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
16
17BBCLASSEXTEND = "native nativesdk"