blob: 6c2ae5e5a1af061e39ef47f16777f4766f624752 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "Hardware identification and configuration data"
2HOMEPAGE = "https://github.com/vcrhonek/hwdata"
3SECTION = "System/Base"
4
5LICENSE = "GPL-2.0+ | XFree86-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
7
8SRCREV = "66a9f63255a06e2d9ec49501188ca47cb537675b"
9SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
10S = "${WORKDIR}/git"
11
12inherit allarch
13
14do_configure() {
15 ${S}/configure --datadir=${datadir} --libdir=${libdir}
16}
17
18do_compile[noexec] = "1"
19
20do_install() {
21 oe_runmake install DESTDIR=${D}
22}
23
24FILES:${PN} = "${libdir}/* \
25 ${datadir}/* "