blob: c905b74d6ed80dabfd62f999376ac7597cdb7b47 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A C++11 library for serialization"
2HOMEPAGE = "https://uscilab.github.io/cereal/"
3
4SECTION = "libs"
5
6LICENSE = "BSD-3-Clause & MIT & BSL-1.0"
7LIC_FILES_CHKSUM = "\
8 file://LICENSE;md5=4921372a1fb38469e667c38b17a1c4b3 \
9 file://include/cereal/external/rapidxml/license.txt;md5=d63ab70ba21ca0544b03284958324301 \
10 file://include/cereal/external/LICENSE;md5=b07578c9df99c0b8b45eb041efd4a645 \
11 file://include/cereal/external/rapidjson/LICENSE;md5=e7abb663111d4ac17cf00323698aff08 \
12 file://include/cereal/external/rapidjson/msinttypes/LICENSE;md5=dffce65b98c773976de2e338bd130f46 \
13"
14
15PROVIDES += "${PN}-dev"
16
17PV .= "+git${SRCPV}"
18SRCREV = "1de8fe89471d69ea392ea260ce74e079d5f4b415"
19SRC_URI = "git://github.com/USCiLab/cereal.git;branch=master;protocol=https"
20
21S = "${WORKDIR}/git"
22
23inherit cmake pkgconfig
24
25EXTRA_OECMAKE = "-DJUST_INSTALL_CEREAL=ON"
26
27ALLOW_EMPTY:${PN} = "1"
28
29RDEPENDS:${PN}-dev = ""
30
31BBCLASSEXTEND = "native nativesdk"