blob: 8f777eb18250be8955175464ffdb3e466f6c3160 [file] [log] [blame]
Andrew Geisslere34f8962021-04-15 15:53:51 -05001SUMMARY = "high level C++ wrapper for rdkafka"
2DESCRIPTION = "cppkafka allows C++ applications to consume and produce messages using the Apache Kafka protocol."
3HOMEPAGE = "https://github.com/mfontanini/cppkafka"
4SECTION = "lib"
5LICENSE = "BSD-2-Clause"
6
7LIC_FILES_CHKSUM = " \
8file://LICENSE;md5=d8b4ca15d239dc1485ef495c8f1bcc72 \
9"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/mfontanini/cppkafka;protocol=https;branch=master"
Andrew Geisslere34f8962021-04-15 15:53:51 -050012SRCREV = "5e4b350806d561473138ce7a982e8f6cf2e77733"
13
14DEPENDS = "librdkafka boost chrpath-replacement-native"
15
16inherit cmake
17
18S = "${WORKDIR}/git"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020do_install:append(){
Andrew Geisslere34f8962021-04-15 15:53:51 -050021 chrpath -d ${D}${libdir}/libcppkafka.so.0.3.1
22}