blob: f9f3baaf2c3ac1f5aab1be5e6d3f2255967a1b15 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "the Apache Kafka C/C++ client library"
2DESCRIPTION = "librdkafka is a C library implementation of the Apache Kafka protocol, \
3 providing Producer, Consumer and Admin clients."
4HOMEPAGE = "https://github.com/edenhill/librdkafka"
5SECTION = "libs"
6LICENSE = "BSD-2-Clause"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=2be8675acbfdac48935e73897af5f646"
9
10SRC_URI = "git://github.com/edenhill/librdkafka;protocol=https;branch=master"
11SRCREV = "063a9ae7a65cebdf1cc128da9815c05f91a2a996"
12
13DEPENDS = "zlib openssl zstd"
14
15inherit cmake
16
17S = "${WORKDIR}/git"
18
19FILES:${PN} += "${datadir}"
20
21EXTRA_OECMAKE += "-DRDKAFKA_BUILD_EXAMPLES=OFF -DRDKAFKA_BUILD_TESTS=OFF"