blob: f519bf2363e15887525bb53dd31eb90ecf08c23b [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
9LICENSE = "LGPLv2.1 | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9"
11
12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
13 file://0001-test-Use-syscall-wrappers-instead-of-using-syscall-2.patch \
14 "
15SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
16SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
17SRCREV = "41a61c97c2e3df4475c93fdf5026d575ce3f1377"
18
19S = "${WORKDIR}/git"
20
21DEPENDS:append:libc-musl = " libucontext"
22XCFLAGS = "-pthread"
23XCFLAGS:append:libc-musl = " -lucontext"
24
25EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
26do_configure() {
27 ${S}/configure --prefix=${prefix}
28}
29do_install () {
30 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
31}