blob: ec68db24563511969e16ddba4f67fc11114f547d [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A recursive directory listing command"
2HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
6
7SRC_URI = "http://mama.indstate.edu/users/ice/tree/src/${BP}.tgz"
8SRC_URI[sha256sum] = "7d693a1d88d3c4e70a73e03b8dbbdc12c2945d482647494f2f5bd83a479eeeaf"
9
10# tree's default CFLAGS for Linux
11CFLAGS += "-Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
12
13EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
14
15do_configure[noexec] = "1"
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 ${S}/${BPN} ${D}${bindir}/
20}